npm安装包报错:npm warn package.json @1.0.0 no repository field.

日期:2019-01-20 15:57:03 类别:  Javascript

最近在学习vue的时候,使用npm安装包,报错:

npm warn package.json @1.0.0 no repository field

这个错误大概意思:缺少repository 字段

解决方法一:

package.json中添加

{
    ...
    "repository": {
        "type": "git",
        "url": "http://baidu.com"
    },
    ...
}

解决方法二:

如果是自己练习写的demo,则可以这样更改配置

{
    ...
    "private": true,
    ...
}