安装eclipse报错:failed to load the jni shared library

日期:2018-12-15 10:12:06 类别:  java web

下载最新版的eclipse后进行安装就报错:failed to load the jni shared library

微信截图_20181215092849.png

报这个错误应该是jdk的位数与eclipse位数不符合导致的。查看自己电脑上面的jkd version

微信截图_20181215092853.png

在eclipse压缩包里面有eclipse.ini文件,里面可以看到下载eclipse的位数

plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.800.v20180827-1352

-product

这里win32.x86_64表示64位,如果是win32.x86则表示32位。

这里就下载32位的eclipse,不更换jdk的位数了。